Sky Go App Not Working with Android ICS 4.0.3

Sky Go App & Android ICS 4.0.3 – App Not Working

Hey up,

After happily upgrading my Galaxy S2 to ICS 4.0.3 I had the unfortunate discovery of noticing that the Sky Go App no longer worked. This seems to be of the fact that SKY as usual are not very swift at updating their apps to follow in line with the latest software.

Anyway… Do not worry, you can download the apk package that will work with ICS 4.0.3 & ICS 4.0.4 . I have it installed on my device and it works great. Download¬†below.

 SKY Go App Compatible with ICS 4.0.3 & 4.0.4

Update – I have also used this .apk file on the Samsung Glaxy S3 and it works superbly.

4 thoughts on “Sky Go App Not Working with Android ICS 4.0.3”

    1. Hi Gary, the sky go app has now been updated to work with 4.0.4 on certain devices, look on the market to see if your device is there.

  1. Hello fella

    I want to install skygo on my samsung galaxy tab2 7.0 it says that my model is compatable now and has been added to the sky list of compatable models but everytime i go into the google playstore to install it says my model is incompatable.. sky have been no help whatsoever so was just wondering if you had any ideas which could help,,

Leave a Reply

Your email address will not be published. Required fields are marked *

8 − 6 =